Linux

Instalar Plugin Adobe Flash para Firefox en FreeBSD 8.2 / Linux Binary Compatibility

freebsd-82

Adobe Flash Player es necesario para reproducir videos en youtube y en muchos alojadores…, FreeBSD no tiene soporte nativo, para ello se necesita compatibilidad linux. Vamos a instalar paso a paso el soporte necesario a FreeBSD para ejecutar Adobe Flash en Firefox.

Leyendo el handbook, encuentro la forma de hacer funcionar el FreeBSD, pero al llegar a cierta instancia me dice que hay un error (www/linux-f10-flashplugin10, luego de hacerle make), entonces leyendo por ahi encuentro que eso se puede corregir, te muestro como:

Parte 1

1.-# kldload linux
2.-linux_enable=”YES”
en /etc/rc.conf
esto ultimo para que inicie con el sistema O en tiempo de inicio.
3.-% kldstat
como simple usuario verificar.
4.-# cd /usr/ports/emulators/linux_base-f10
# make install distclean

Deberia funcionar. Ya tenemos compatibilidad linux, se descargaron varios rpms (gracias fedora project)

Parte 2

1.-freebsd# whereis linux_base-f10<

linux_base-f10: /usr/ports/emulators/linux_base-f10
freebsd#
2.-cd /usr/ports/emulators/linux_base-f10
make
make install
make clean<
3.-freebsd# whereis nspluginwrapper
nspluginwrapper:/usr/ports/www/nspluginwrapper
freebsd#
cd /usr/ports/www/nspluginwrapper
make
make install
make clean
4.-freebsd# whereis linux-f10-flashplugin10
linux-f10-flashplugin10: /usr/ports/www/linux-f10-flashplugin10
freebsd#

ingresamos al directorio y hacemos:

make

Nos dice que algo fallo y que no se puede continuar, intento otra vez y nada, pero poniendo:

make makesum
make install
make clean

lo hago en lineas distintas, manías mias.

5.-freebsd# ln -s /usr/local/lib/npapi/linux-f10-flashplugin/libflashplayer.so /usr/local/lib/browser_plugins/
6.-$ nspluginwrapper -v -a -i
Auto-install plugins from /usr/local/lib/browser_plugins
Looking for plugins in /usr/local/lib/browser_plugins
Install plugin /usr/local/lib/browser_plugins/libflashplayer.so
into /home/edgar/.mozilla/plugins/npwrapper.libflashplayer.so
Auto-install plugins from /home/edgar/.mozilla/plugins
Looking for plugins in /home/edgar/.mozilla/plugins
$

Esto ultimo como dice para cada usuario (handbook:by each user with nspluginwrapper)

Por: Edgar.

Acerca del Autor

AbelRL

1 Comentario

Clic Aqui para Publicar un Comentario

  • Información Bitacoras.com…

    Valora en Bitacoras.com: Adobe Flash Player es necesario para reproducir videos en youtube y en muchos alojadores…, FreeBSD no tiene soporte nativo, para ello se necesita compatibilidad linux. Vamos a instalar paso a paso el soporte necesario a Fr……